PS4 The add-on for the following application is corrupt


New member
Apr 25, 2023
Alright so, i tried to download a game last week and after about 15 minutes into playing I received the error: “cannot continue using the application. The add-on for the following application is corrupted. You must delete the data and redownload.” there is not an actual error code, just the error message. I can even hear the game running in the background of the error message. I tried several things to fix this including obviously redownloading multiple times, but no luck. About a week later I put in a different game to try and download, same problem. So I decide to just download the game on my husbands PlayStation. SAME PROBLEM. So I search for answers again, end up restoring licenses and that seemed to help. I was able to play that day for several hours no issues. The next day I try to play and same problem as before. There aren’t issues with any other applications, I can play games that were previously downloaded on both PlayStations without issue. I’m truthfully at a loss with this one. It is especially perplexing that the same exact thing happened on my husbands PS4. This is not an error I have ever encountered in my 10-ish years of playing PS4. Has anyone dealt with this?