Save File Gone ENTIRELY | Final Fantasy 7 Rebirth


New member
Mar 11, 2024
I played a game last night, like I did the night before. I saved the game and turned off the PS5. I woke up today, and it's like to save data never existed. I have PS+. I have all the options activated that would save my data to the cloud. I go and check said data, and it only shows when I tried to go into the game and load my save and saw that it was gone. When I tried to download said data, it only had the data from today; when I saw that my actual save data is missing. So far, from what I'm reading, everything leads to it being gone. I'm pissed because even the fail-safes failed.

When I look at the game from the home menu, it still shows my progress, except it's completely gone. It's not even in the cloud. I don't need help. I'm just venting. 43h of time WASTED.

Why did my game save, that was supposed to be saved to the cloud get deleted entirely? It was completely gone, and I was playing it last night! The only cloud data that was left was when I opened up the game this morning to see that it was missing. When I went to try and download my save data from the cloud, it only had the data from when I opened the game this morning. The game is Final Fantasy VII Rebirth. I deleted that completely as it was deemed absolutely worthless. So 57% of my save data disappeared overnight with the PS5 completely shut off. I'm livid.
Last edited:
The response I got back from support:

"Im truly sorry about this issue, unfortunately you must got this file overwriten. Unfortunately there is no way to restore saves files that where deleted from the cloud, and there is no report of this activities. Apologies."