PS4 system software won't install on Crucial MX500 1TB


New member
Jan 4, 2024
Wanted to upgrade to an SSD to cut down load times, but can't seem to get it to work.

Installation initializes fully with the MX500 and then prepares installation up to 58%, then suddenly jumps to 65%, and errors out with "SU-30625-6 the installation file is corrupt".

I put in a the old spinning rust disk and it installs just fine, but won't do it on the new one.

I've cleaned and formatted the SSD in different ways, even deleted and set the partition table to GPT to hose out any hidden partitions or encryption.

Before attempting this I researched and this particular SSD came up as a good candidate for PS4. Was this just bad info and it's incompatible? Or am I missing something else?

Any suggestions highly appreciated.
I would’ve expected the PS software to format the drive before installing so you could try diskpart on a PC to clean the drive & once blank to fit it back into the PS4 & run the software installation again.
Right click Start>Powershell/Termincl with admin & enter these cmds:
list disk
select disk X (where X is the number of PS4 SSD)

Have you also tried redownloading the installation files onto a USB?

Also have you tried installing within safe mode?
Does the router have a firewall? If so try disabling this.
Is the PS4 connected via Wi-Fi or Ethernet? If Wi-Fi can you try ethernet connection?
I use linux so I zeroed the disk using dd. (dd if=/dev/zero of=/dev/x) That's the Windows equivalent to diskpart->clean with an extra step of actually destroying all the data as well as just removing links. Then I rebuilt the partition table to GPT. Should be like new out of box after this.

I tried a whole bunch of different USB drives. The thing that really makes me crazy is that I can install it back on the old spinning rust disk, with 2 different USB sticks, so the installation file is known good.

Do you think it's maybe just a bad SSD?
Possible. Another possibility is that it is a fake drive & the capacity is much less than expected. Was the drive very cheap?
Have you tried creating an mbr partition as the ps4 most likely came out before gpt. Also try cleaning the drive again but allowing the ps4 to format it.

It seems the ps4 is peculiar when it comes to SSD & requires using the usb + same mode method to install the software.
It's a legit drive with hologram and serial.

Setting table to mbr or straight up removing partition tables altogether is a great idea, I'll try that. Thanks.