Problem with additional internal SSD


New member
Mar 13, 2024
Hi there,
I have been needing a storage expansion so I decided to buy an internal SSD for the expansion slot. After looking for the best options, I ended up purchasing a SN850 WD_BLACK 1TB with built-in heatsink, which seemed to be one of the most popular options for the PS5.

I tried installing it, but something's wrong. Here's what I did:

I took off the plate, unscrewed the expansion slot bolt and opened it, unscrewed the spacer bolt, placed the spacer in the correct slot (80), inserted the SSD at an angle, then screwed the spacer bolt, reattached the expansion slot and bolt, and put the plate back.

I then connected the PS5 back to the power outlet and turned it on... and nothing. It turned on as normal but nothing changed. No prompt to format the SSD, nothing new in the storage settings. So I turned it off and unplugged it again, so I could re-do the whole process and see if I had done something wrong... and I had! The SSD was not properly connected, if I touched it with my finger and tried to gently wiggle it, it would move slightly, which I found odd, and I remembered I did not hear a click when plugging it in, which I should have.

So I did everything again, but this time made sure to be extra careful when inserting the SSD, and this time I put it correctly at the right angle, and heard the click! Before putting the spacer bolt on I realized it was also at a much smaller angle than before (which meant it was completely out of place?). It also stood perfectly still this time around when trying to do what I did before with my finger. Feeling confident that I had gotten it right this time around, I finished the rest of the steps and plugged the PS5 again. And... nothing. As before, it turned on, but didn't get any prompt to format the drive, nor does it appear in the settings, which means it is still not recognizing it.

What else can I do? I did everything correctly the second time around (besides the fact that I might have used the wrong screwdriver for the spacer bolt the first time around which meant unscrewing it for the second round was a bit harder than usual since the head was kind of worn, but nothing that would justify this)
UPDATE: I made some experiments with a friend and turns out the SSD was faulty. It never worked in any other board (and the LEDs never lit up either), there was a dent that indicated there might have been some bloatage going on, and putting another SSD in the PS5 worked without a problem.