Issues with m.2 SSD install/pcie slot


New member
Oct 20, 2023
I hope this is allowed here, please delete if it is not. I decided to utilize my expandable storage on a PS5 Disc edition. I have scoured the internet and can't find the combination of the two problems below, mostly just fixes on a PS5 not recognizing the m.2. Here are the troubleshooting steps I have taken:

1.) Install compatible drive in pcie slot, it worked but since the heatsink wouldn't fit, after about 30 minutes of play time i decided that I didn't want to risk anything, returned and ordered a second drive.

2.) Second drive was not recognized, with and without heatsink on the drive. Didn't have a pcie slot at home to test, swapped out from Amazon, same issue with replacement. During this time, another issue arose. Now, with or without the drive in, I keep getting the error regarding a drive being in the slot and it not being recognizable. Both with and without the drive inserted, I'm getting the same error message. Have gone through every troubleshooting step in Safe mode, even purchased a third drive and to no avail.

Has anyone ever run into this problem? This is seeming like maybe the pcie slot is damaged or something, but I'm hesitant to take the whole unit apart due to warranty issues (are there?), but that seems like the next logical step. I have a ticket in with PS Support and they are sending me a box/return label for an RMA. I'd prefer not to wait a month+ and figure it out myself, but I'm running out of ideas here.

Anyone ever experienced this?