Disc reader issue

Joined
Apr 9, 2022
Karma
0
Alright, so I am a Playstation 5 owner, so this isnt a big concern, but I would still like to know.

My Playstation 4 was working perfectly fine, I was using MegaMan Legacy Collection and Gran Turismo Sport the same day this happened, and they were working fine, however, I own Farming Simulator 17, and my disc wasnt working, but I didnt know if it was working or not, I figured it could do no harm to try putting the disc in my Playstation 4. I put it in, and the console recognised the game, but had an error trying to load it, so I deleted the game (with the exception of save data), and retried copying it from the disc, and it had an error mid download and couldnt download more, apon trying to unpause the download, it tried to download again, and the same download error occured (with no new download progress made), I ejected the disc, wiped it off, put it back in, it still didnt work, I ejected again, and put it in my Playstation 5, it didn't work, I decided to try putting it in my Playstation 4 one more time, and this time things were different. I put the disc in the slot carefully as I always do, and it accepted the disc into the slot, but the system gave no sign of knowing there was a disc in the system, so I hit eject, and nothing happened, not only did the disc not eject, but the Playstation didnt make the beeping noise it makes when it thinks there is no disc, it was just silent. Worrying that I had encountered a dumb random error, I restarted the system, and hit eject as the system turned on, and the disc had no problems ejecting, so I tried putting the disc in one more time to see what would happen, and the exact same scenario repeated itself, with the exception of the fact that, without a restart, when I hit the eject button, the disc came out fine. So I decided to try putting the disc in the Playstation 5, and as expected "unrecognised disc". But none the less I figured it was just an issue with the disc, after all, it was a faulty disc, but the next day, I put in MegaMan Legacy Collection 2, which is a disc that I know works, and the Playstation 4 did the same thing, it didn't even show any sign of knowing there was a disc in, aside from activating the motor to pull the disc in when I put it in the slot, and ejecting as normal apon the pressing of the button. I know this disc works because my Playstation 5 is reading it perfectly fine, and I can play the game as normal on that console. My Playstation 4 however, seems to no longer even attempt to read discs put in the slot. Does anyone know the problem, and if I can fix it? (I dont want to oppen up the console myself, but I am willing to take it to a shop to do so, if I end up needing to.

P.S. I got a disc clean and fix machine, and ran Farming Simulator 17 on my Playstation 5, works without any errors now, but the Playstation 4, just like with all of my other games, isnt even attempting to read the disc.

And yes, I am pretty sure my downloaded games still work.
 
Last edited:
Top